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'405 Method Not Allowed Error' when Starting Insight Applications

Article # 3040556 - Page views: 6

Issue 

What causes a '405 Method not allowed' error and how can it be resolved?

Cause 

This is related to configuration of either IIS and / or Insight.

Solution 

This is related to configuration of either IIS and / or Insight.  Here are some suggestions to help resolve this:

  • Verify all additional features for IIS were enabled - especially WCF Activation. Refer to the Insight Installation Guide for all IIS feature requirements.
  • Verify GET and POST methods are allowed in IIS
  • Verify all 8 Insight applications are running under a single app pool in IIS' Applications Pools tree.
  • Starting in v6.0, iFrames are disabled. To enable, change the following (bold/underlined) to ALLOW via Program Files\Kofax\Insight\HTMLInsight\web.config:

<httpProtocol>

                           <customHeaders>

                                      <add name="X-Frame-Options" value="DENY" />

                           </customHeaders>

</httpProtocol>

 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
Kofax Insight 6.x      

References

Add any references to other internal or external articles

 

Article # 3040556
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