'Couldn't check database' error During Log into Dashboard
Article # 3039322 - Page views: 39
Issue
Insight user is attempting to log into their default dashboard view and getting this error.
Cause
Missing Tablet and Phone Default views in the Role.
Solution
Edit the user's default role by setting a default view for PC, Tablet and Mobile devices. This can be configured in the role's View Rights tab by selecting a view, then clicking the three buttons at the bottom: PC Default, Tablet Default and Phone Default.
This issue can occur if a desktop PC has a touchscreen device. That may send tablet-related metadata in the browser trace which Insight interprets as a non-PC device. This is expected Insight behavior.
Insight v6.3 and newer will report the following error to the user:
"Project with id 00000000-0000-0000-0000-000000000000 is not found."
Level of Complexity
Easy
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Insight | 6.x.x |
Article # 3039322