HTTP 500 Timeout Errors Exporting Large Excel files
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Issue
When attempting to export large Excel files, HTTP 500 error is thrown with the following text in Viewer's log. What causes that and how can it be resolved?
ERROR Insight.App_Code.serviceHandler - https://127.0.0.1/WcfDataService/Htm.../ExportToExcel System.Threading.ThreadAbortException: Thread was being aborted.
Cause
Service handler timeout.
Solution
This issue occurs when the service handler times out before the data service can provide a response. In v5.x, the default timeout is 90 seconds. To fix this, modify the Viewer application's web.confg file as follows:
- Backup existing copy of \Program Files\Kofax\Insight 5.4.0.0\HtmlInsightView\View\web.config
- Edit the file and note the following section:
3. Add the following entry to the existing httpRunTime line:
- Save the file
- Perform an IIS reset or restart the Insight 5.4 Application Pool
- Test
Level of Complexity
Easy
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Insight |
5.x 6.x |