Insight Admin Console License Manager Save License shows with Not Found 404 Error
Issue
When attempting to save a License File within the Kofax Analytics for Capture - Insight Admin Console - License Manager, then an Error Message is received stating "Couldn't save license' and Not Found(404) errors. Additionally, the Details for the error references the IIS Request Filtering settings:
HTTP Error 404.7 - Not Found
The request filtering module is configured to deny the file extension.
Most likely causes:
Request filtering is configured for the Web server and the file extension for this request is explicitly denied.
Things you can try:
Verify the configuration/system.webServer/security/requestFiltering/fileExtensions settings in applicationhost.config and web.config.
Detailed Error Information:
Module RequestFilteringModule
Notification BeginRequest
Handler serviceHandler
Error Code 0x00000000
Requested URL http://localhost:80/Insight/Admin/se...rv/saveLicense
Physical Path F:\Program Files\Kofax\Insight 6.0.0\HtmlInsight\Admin\serviceHandler.srv\saveLicense
Logon Method Not yet determined
Logon User Not yet determined
Cause
As defined within the error details, the cause of the issue is due to the IIS Request Filtering configuration for the Kofax Analytics for Capture web sites.
Solution
Modifying the Request Filtering may resolve the issue, as follows:
- Launch the IIS Manager (inetmgr.exe)
- Connections: Expand the Sites and select 'Default Web Site'
- Default Web Site Home - IIS - Request Filtering - Open Feature
- Edit Feature Settings:
- Check to Enable "Allow Unlisted File Name Extensions"
- Check to Enable "Allow Unlisted Verbs"
- Save changes and restart the IIS Application Pools
Level of Complexity
Easy, Moderate, High
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Analytics for Capture | All |
References
Add any references to other internal or external articles