Reports Self-Subscription: Unable to Select Reports
Issue
Creating a self-subscription report but none of the reports can be selected (view appears to be disabled).
Cause
Users accessing the report do not have e-mail address configured.
Solution
When creating self-subscription reports, regardless of viewer authentication scheme, users must have an e-mail address configured. For Insight users, configure Admin | Users by adding an email address for each user that needs access to the report.
For non-Insight authentication, configure User Mapping | Email tab. For example, if you are using Windows or HTTP authentication, the users' ASP.Net session information is written to the WcfDataService log. Have the user log into viewer app, then review that log. Sample field to use in the Email tab may be mail or userPrincipalName:
userPrincipalName: john.smith@abc.com
mail: john.smith@abc.com
Note: This feature will display all reports, including any still being designed or old reports no longer used, as long as the user has permissions to them under their assigned role(s). To remove any reports not needed, remove permissions from the role(s).
https://docshield.kofax.com/Insight/...html?h=reports
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Insight | 6.x |
References
Refer to the Online Help for the Insight version you are using (Studio)
Article # 3046306