Server is in single user mode
Issue
Kofax modules do not start and in Kofax Capture error log is following entry found:
Login failed for user 'sa'. Reason: Server is in single user mode
How can the database be set to multi user mode?
Cause
Due manual setting or update installation the database is set into single user mode to proceed with exclusive access to the database and carry out the update.
It can happen this setting is not reverted.
Solution
To change the database back to multi user mode there are different options:
1. Open SQL configuration manager
2. Under services choose the SQL server service where your Kofax Capture instance is residing
3. Open properties and open tab "Startup"
4. Verify that "-m" is not present
5. Restart the SQL database and Kofax Capture Service
Second option to set database from single user mode to multi user is to use SQL Management Studio:
1. Open SQL management studio and connect to your Kofax Capture Database
2. Open properties of your database
3. Options -> scroll to the bottom and change "Restrict Access" to "Multi_User"
4. Restart the sql service and also the Kofax Capture service
Level of Complexity
Easy
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Capture | 11.x |
References
16170