Skip to main content
Kofax

Username or Password supplied in the processModel section of the config file are invalid error connecting to a Central Site

587
3012943

Question / Problem: 

Cannot connect the Remote site to the Central site KCNS Server, receiving a message stating the web server is unavailable. The Central site KCNS server Application Event log reports "aspnet_wp.exe could not be launched because the username and/or password supplied in the processModel section of the config file are invalid." How can I fix this?

Answer / Solution: 


This error happens when the KCNS Server is installed on a Domain controller. This is a known Microsoft bug. The default account for running ASP.NET's worker process does not exist on a Domain controller. This is described in detail in Microsoft's knowledge base article # 315158: https://support.microsoft.com/en-us/help/315158

Microsoft provides 3 workarounds for this problem:
* Create a weak account that has the correct permissions, and then configure the "processModel" section of the Machine.config file to use that account.
* Set the userName attribute to SYSTEM in the "processModel" section of the Machine.config file.
* Configure the "processModel" section of the Machine.config file to use an administrator account.

For security reasons, Microsoft recommends the first option. Instructions for completing the recommended workaround are available in article #315158 in the Microsoft Knowledge Base. Related info can be found in articles #317012 & #811320.

 

Applies to:  

Product Version
CAPTURE 11.0
  10.2
  10.1
  10.0