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Opening and Closing of Batches in any Capture module is very slow

Article # 3031701 - Page views: 459

Article # 3031701 - Page views: 459

Issue

The opening and/or closing of Batches in any Capture module is severely slow or delayed

Cause

  • Network/Proxy/Firewall
  • Database
  • Bad Configuration

Solution

1. Kofax Reporting flushes statistical data to disk upon the closing of a Batch, therefore a delay might be due to accessing the storage which is located at %ALLUSERSPROFILE%\Kofax\Reporting\Client\Log.  If Kofax Reporting is not being actively used, it should be disabled to speed up opening and closing batches.

To disable Kofax Reporting:

A.      Back up the current ACConfig.xml file.

B.      Add the following element to the \\<ServerName>\CaptureSV\Config\ACConfig.xml file to the bottom right above the </ACConfig> closing tag:

<ACConfig>

    <Reporting Enable="2"/>

</ACConfig>

C.      Save this change.

D.      Restart the Kofax Capture service from the Service Control Manager.

2. This type of behavior is most often cause by the client firewall on the Windows OS. It will be necessary to allow exceptions:

There are multiple ways to achieve this.

On the Windows Firewall, you can open either ports manually or allow processes (executables). It is suggested that allowing processes is easiest. The processes that you need to allow are:

Folder - exe

C:\Program Files (x86)\Kofax\CaptureSS\ServLib\Bin ACSvc.exe

C:\Program Files (x86)\Kofax\CaptureSS\Server\MSSQL10_50.KOFAXCAPTURE\MSSQL\Binn - sqlservr.exe

C:\Program Files (x86)\Microsoft SQL Server\90\Shared - sqlbrowser.exe

The folder in which sqlservr.exe resides will vary slightly between versions.

3. If Active Directory Linked Users are used, the following can be used to get extra logging around poor performance in the start up of modules.

A.      Stop any Kofax services (modules) that are running on the system.

B.      Open System Properties (Right-click on Computer or My Computer and select Properties, then select Advanced System Settings).

C.      Select the Advanced tab.

D.      Click the Environment Variables button.

E.       Create a new System variable named KCUserProfileLoggingEnabled.

F.       Set the parameter value to True.

G.     Start any Kofax Capture services stopped in Step 1

The log file, named KCUserProfile.txt, can be found in the \\CaptureSV\Logs folder.

4. A SQL Profiler trace can be useful when the Kofax Capture database has been migrated. You can add the following events:

Locks

Deadlock graph

Stored Procedures

SP: Completed

SP: Starting

SP: StmtCompleted

SP: StmtStarting

TSQL

SQL:BatchCompleted

SQL:BatchStarting

5. A good starting point is to perform a network trace from a few machines interacting with the CaptureSV share that resides on this NAS. Look for any protocols making excessive calls (such as SMB for example).

If any chatty protocols can be identified and linked to some machines (as the source), run Process Monitor to map the lower level protocols to a particular process on the machine.

Check to see if Log4Net logging is part of your Kofax solution. If it is, review for any type of file watching being performed (i.e. file watcher calls) that may be monitoring for file changes somewhere in the CaptureSV share. This file changes would trigger a file system "file change notification" request (or seen in Procmon as a NotifyChangeDirectory operation).

6. This problem was seen, if the dynamically assigned Port which is stored in the registry key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MicrosoftSQLServer\KofaxCap2008R2\MSSQLServer\SuperSocketNetLib\Tcp\TcpPort

is blocked by the firewall of the server.

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
Kofax Capture 11.x N/A N/A N/A

References

21015, 20931, 20445, 17368

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