Ricoh MFP Java Client Configure TLS Cipher Suites
Article # 3036155 - Page views: 59
Issue
How to determine which TLS Cipher Suites are supported by a Ricoh MFP Device and how to enable or disable TLS Cipher Suites used by the device
Cause
The MFP Device and the server must share at least one enabled TLS Cipher Suite for HTTPS communication to succeed.
Solution
- Log into the Ricoh MFP device's web interface (Web Image Monitor) using administrator credentials
- Navigate to Device Management | Configuration | Extended Feature Settings | Administrator Tools
- Most newer Ricoh MFP Devices will list the available TLS/SSL Cipher Suites as "(SSL Suite)" in the Select Available Functions section.
Older Ricoh MFP Devices may not list available TLS /SSL Cipher Suites or give the user the ability to determine which Cipher Suite is used for HTTPS communication. The best way to determine which TLS Cipher Suites these devices support is to perform a network trace from the server using a network traffic tracing utility such as Wireshark
- Set at least one Cipher Suite that the server supports to
Active
- Set any Cipher Suites that are not supported by the server to
Inactive
- Click
Apply
- Note which TLS Cipher Suites are enabled and make sure that the server also has that Cipher Suite enabled.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Front Office Server | 4.3 4.1 |
ALL | ALL | Ricoh MFP Devices |
Kofax TotalAgility | 7.9 7.8 7.7 7.6 7.5 7.4 7.3 |
ALL | ALL | Ricoh MFP Devices |
References
N/A