Ricoh MFP Android Client Cannot Connect to Server Network Problem or Disk Full
Article # 3036225 - Page views: 48
Article # 3036225 - Page views: 48
Issue
Attempts to connect to the KFS server from the Ricoh MFP (Android) Client result in the following error:
Cannot connect to server. There is a network problem, or the disk on the server is full.
Cause
The Kofax Ricoh MFP Android Client's Cannot connect to server
error can be triggered by a number of root causes.
Known root causes include:
- Incorrect server URL in
KofaxRicohAndroid.dalp
file - Device cannot successfully use DNS to resolve the hostname or Fully Qualified Domain Name of the KFS server
- Connection refused by KFS server due to insufficient free space on server or Capture share
- HTTPS connection fails due to server configured for HTTP only
- HTTPS connection fails due to TLS version mismatch
- HTTPS connection fails due to TLS Cipher Suite mismatch
Solution
To troubleshoot and resolve Ricoh MFP Android Client connection issues:
- Confirm that the server URL is correct in the
KofaxRicohAndroid.dalp
file
- Configure Ricoh MFP Device DNS settings
- Confirm that the KFS server and Capture share have sufficient available free space
- (HTTP only) Configure Ricoh MFP Client to use HTTP communication with server
- (HTTPS only) Configure the KFS server to accept communication over HTTPS
- (HTTPS only) Use Wireshark to Troubleshoot Problems with TLS Handshake
- (HTTPS only) Determine which TLS version(s) the device can support and configure the device to use at least one TLS version that is enabled on the server
- (HTTPS only) Determine which TLS version(s) are enabled on the server and configure the server to use at least one TLS version that the device can support
- (HTTPS only) Determine which TLS Cipher Suites the device can support and configure the device to use at least one Cipher Suite that is enabled on the server
- (HTTPS only) Determine which TLS Cipher Suites are enabled on the server and configure the Enablement and Order of the Cipher Suites to prioritize at least one Cipher Suite that the device can support
Level of Complexity
High
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Front Office Server | 4.3 4.1 |
ALL | ALL | Ricoh MFP Devices |
References
- Ricoh MFP Client Cannot Resolve KFS Server Hostname
- Connection to KFS Server Refused due to Insufficient Drive Space
- Configure Ricoh MFP Client to use HTTP communication with server
- Configure KFS 4.3 to Accept Secure Communication over HTTPS
- TLS Handshake Troubleshooting Using Wireshark
- Ricoh MFP Android Client Configure TLS Versions
- TLS Version Configuration in Windows Server
- Ricoh MFP Java Client Configure TLS Cipher Suites
- TLS Cipher Suite Configuration in Windows Server