Ricoh MFP Client Cannot Resolve KFS Server Hostname
Issue
The Kofax Ricoh MFP Client cannot resolve the hostname or Fully-Qualified Domain Name (FQDN) of the KFS server, resulting in the following error:
Cannot connect to KFS server. There is a network problem, or the disk on the server is full.
Cause
The Ricoh MFP device is not configured to point to a DNS server that can resolve the hostname or FQDN of the KFS server or (in the case of a load balanced KFS server cluster) the load balancer/proxy server.
Solution
- Log into the MFP device's web interface (Web Image Monitor) using the device administrator login credentials
- From the menu on the left, select Device Management | Configuration
- In the Network section, click IPv4
- Under Details, if the DNS Server field is set to Auto-Obtain (DHCP), select the Specify radio button
- In the DNS Server1 field, enter the IP Address of a DNS server that is known to be able to successfully resolve the hostname or FQDN of the KFS server or load balancer/proxy server
- Enter the IP Addresses of another known good DNS server into the DNS Server2 field
- Click OK
The navigation within the Web Image Monitor may vary by model. Consult the Ricoh MFP device's documentation for the correct location of the DNS settings.
Alternate Solution
If the IP Address of a DNS server which can resolve the hostname or FQDN of the KFS server or load balancer/proxy server is not known, an alternate solution would be to configure the Ricoh MFP Client to connect to the KFS server or load balancer/proxy server using its IP Address.
To configure the Ricoh MFP Client to connect to the KFS server or load balancer/proxy server using its IP Address:
- Uninstall/Unregister the Ricoh MFP Client from the device
- Log into the KFS Administration Console
- Navigate to Settings ¦ Advanced
- In the
kfs.properties
namespace, change the ProxyServer value to the IP address of the KFS server or load balancer/proxy server
- Click Save
- Navigate to the Devices screen
- Download the Ricoh Client. During the download process, the connection URL in the .dalp file will be updated with the IP Address from the ProxyServer field.
- Install or Register the new copy fo the Ricoh MFP Client to the device
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Front Office Server | 4.3 4.1 |
ALL | ALL | Ricoh MFP Devices |