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Kofax

Batches Routed to Wrong Destination

Article # 3032191 - Page views: 125

Issue

Emails imported with Kofax Import Connector (KIC) Email are not routed to the correct Destination, which results in batches based on the wrong Batch Class being created in Batch Manager.


How can I resolve this issue?

 

Cause

Usually this issue indicates the KIC rule created for the KIC Plug-in is either incorrect or missing and the file is forwarded to the default destination.

 

Solution

Please apply the following troubleshooting steps:

1. Review the KIC KC-Plugin log file (Default location: C:\ProgramData\Kofax\KIC-ED\KCPlugIn\Log) and verify that the "Destination match not found" entry is recorded. If it is, it indicates that there is an issue when KIC is trying to find the matched Destination setting for the email. The complete entry should be similar to the followings:

2013-05-03 09:00:29,859 INFO [Thread=10] [DestinationLookup] Looking up destination queue
2013-05-03 09:00:29,859 INFO [Thread=10] [DestinationLookup] 

Address:test-to@kic-ed.com
2013-05-03 09:00:29,859 INFO [Thread=10] [DestinationLookup] 

Recipientlist:test-to@kic-ed.com,

2013-05-03 09:00:29,859 INFO [Thread=10] [DestinationLookup] Destination match not found.Dispatching to default destination.
2013-05-03 09:00:29,859 INFO [Thread=10] [DestinationLookup] Default destination: 
Destination1

 

2. Review the KIC Connection ¦ Rule ¦ Address configuration. Make sure that the "Address" in the Rule setting matches the one listed in Step 1 above.

3. Review the message.xml <DisplayTo> element. Make sure that the "Address" listed in the <DisplayTo> element matches the one listed in Step 2 above. If it doesn't match, it indicates that the email has been forwarded by the email server, which causes the issue.

 

Level of Complexity 

Easy

 

Applies to  

Product Version Build Environment Hardware
KIC 2.x      

References

18008

307831

 

Article # 3032191
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