KIC has stopped connecting to the mailbox
Issue
We are polling a mailbox via MSGraph. This has been working for a number of months, but it has all of a sudden stopped working.
After clearing the IE cache the issue persists. The login window appears and the mailbox is Authorized successfully but the "Test Mailbox" button stays grayed out so the connection cannot be created/activated.
I can see this error in the KIC logs:
2022-02-01 10:08:37.597 DEBUG [Thread=6] [Kofax.KCS.ImportConnector.Config.ConfigInfo] <-UpdateConfigFileWithNewParameters()
2022-02-01 10:08:37.597 DEBUG [Thread=6] [Kofax.KCS.ImportConnector.Config.ConfigInfo] Acquired Mutex inside LoadTokenCacheIfAny
2022-02-01 10:08:37.598 ERROR [Thread=6] [Kofax.KCS.ImportConnector.Config.ConfigInfo] Exception occured while acquiring Mutex inside GetCachedTokenInfo(). Message is :: Unterminated string. Expected delimiter: ". Path 'OAuth2TokenInfo['EMAIL.TEST@GROUP.COM_BE91B542-AB55-49C0-AD1A-935BFA8603D5_MSGRAPH'].RefreshToken', line 9, position 942
Cause
The issue is caused by corruption of the OAuth2TokenCache.cache which contained miscellaneous characters (braces, curly brackets, or squiggly brackets).
C:\ProgramData\Kofax\KIC-ED\KCPlugIn\config\OAuth2TokenCache.cache
Solution
Delete the file and then authorize the MS Graph Mail connection. This then resolved the issue.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
KIC | 2.9 |
References
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