User Console Error: 'Application error page. An unexpected error has occurred on the web server.'
Issue
This error displays only when launching User Console. Admin Console works fine and monitors can be created and implemented without any issues, however, export feature also fails.
Cause
Conflict with MySQL .Net Data provider. The Monitor server also has MySQL .Net data provider and database engine installed.
Solution
- Backup web.config file located on Monitor server's <KM install path>\Program Files (x86)\ReveilleSoftware\Reveille\Web\Reveille folder.
- Scroll down to the <Providers> section under <System.web> and add in the line to remove MySqlSiteMapProvider as follows:
3. Save web.config file.
4. Restart User Console and confirm issue resolved.
Here is a excerpt from the error stack:
6/17/2022 12:51:22 PM: Debug [<redacted>:Administrator] ReveilleMonitorService - Execute SQL: Select Monitor, Action FROM Monitor WHERE Server=? AND Action <> 0 ORDER BY Monitor
6/17/2022 12:51:09 PM: Error [<redacted>:Administrator] UserConsole - UserHost Address:::1 - System.Configuration.ConfigurationErrorsException: The connection string name is missing for the MySqlSiteMapProvider (C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\machine.config line 275) ---> System.ArgumentException: The connection string name is missing for the MySqlSiteMapProvider
at MySql.Web.SiteMap.MySqlSiteMapProvider.Initialize(String name, NameValueCollection config)
at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)
--- End of inner exception stack trace ---
at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)
at System.Web.Configuration.ProvidersHelper.InstantiateProviders(ProviderSettingsCollection configProviders, ProviderCollection providers, Type providerType)
at System.Web.Configuration.SiteMapSection.get_ProvidersInternal()
at System.Web.SiteMap.Initialize()
If the above steps do not resolve this issue, continue troubleshooting as follows:
- Run the Kofax Monitor Pre-Requisite check and verify all requirements are met.
- Verify the ODBC 32-bit DSN connects successfully.
- Verify the KM database by using ReveilleDBMigration from <KM install path>\ReveilleSoftware\Reveille\Support\UpdateDB folder and verify no errors are found.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Monitor | 8.x |
Article # 3047621