Skip to main content
Kofax

Archive process stopped

Article # 3038196 - Page views: 42

Issue

The following behaviour is observed: The archive module runs but doesn't archive messages from the TCOSS short term archive.
Within KCS monitor, the archive module shows "Last error code 308 max. store capacity reached."

Cause

The storage location to store Online Volumes ran full resulting in no new Online volumes being created.

Solution

Depending on how TC/Archive is configured you need to apply different solution.

  • TC/Archive with only an Online volume store.
    • Without disk space limitation. The archive will use up the total capacity of the logical drive to store archive volumes.
      Example: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Topcall\TCARCH\VolumePathList = E:\TCARCH\VOLUMES

      Solution:
      • increase the amount of disk space that's available for the configured disk, in this case, the E:\ drive.
      • or add an extra volume path on which archive volumes may be stored.
        Note-Icon.png

        NOTE: Do not change the entry order in the VolumePathList of an existing archive.

        Example:
        Screenshot 2022-01-18 175355.png
         
    • With disk space limitation. The archive will use up the defined disk space of the logical drive. Example below, the disk space for archive volumes is limited to 8 GB.
      Example: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Topcall\TCARCH\VolumePathList = E:\TCARCH\VOLUMES,8192.

      Solution:
      • increase the configured disk space limit if the logical drive has free space.
        Example: E:\ drive has a size of 80 GB and there is still 40 GB free. You could then f.i. increase disk space limit to E:\TCARCH\VOLUMES,16384.
      • or add an extra volume path on which archive volumes may be stored.
        Note-Icon.png

        NOTE: Do not change the entry order in the VolumePathList of an existing archive.

  • TC/Archive with Online volume store and Offline volume store.
    Screenshot 2022-01-19 093538.png Screenshot 2022-01-19 095947.png
    Short info on Network Storage support:
    The idea of operation is that closed archive volumes are automatically written to a network share (Network Storage location).
    The local disk space of the archive server is used to build-up new volumes, to store some of the more recent volumes and the complete index (in index volumes).
    All other volumes are "offline" or not stored on the local disk of the archive server, but are assumed to be accessible on the network share.
    The administration of the network share has to be done manually by the customer. The data files on the network storage are only opened by the archive process when they are actually accessed and closed again immediately. The files are not locked permanently and may be easily removed or copied back.
     
    • In case Online volume & Offline volume store gets full.

      Solution: [Please use the option that most suits your needs]
      • remove old Offline volumes that were backed up by means of e.g tape backup, resulting in free disk space on the Network storage location.
        In this way, the automatic copy operation of closed Online volumes to Offline volume store, can continue.
      • or increase the disk space for the Offline volume store (Network storage location). In this way there will be more disk space available on the Network storage location so the automatic copy operation of closed Online volumes to Offline volume store can continue.
      • or implement a solution mentioned in the section "TC/Archive with only an Online volume store".

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
Kofax Communication Server All   Windows  

References

Add any references to other internal or external articles

 

Article # 3038196
  • Was this article helpful?