Skip to main content
Kofax

Licences expired on virtual server after a restart

Article # 3038034 - Page views: 23

Issue

After a restart of the Kofax Communication Server (KCS) server, TCOSS & the links may fail to start with a licensing error

Cause

The KCS software is licensed against  the CPU number which is generated from the MAC address of the first network card of the server.
If the MAC address of the server is not locked, the CPU number can change when the Virtual server is moved to a different host.

Solution

Check the KCS license tool (License Maintenance) and check the CPU number displayed against the CPU number on the licenses.
If the number is different there are 2 options.

First (& the quickest) possible solution is to restore the Virtual server back to the original host causing the CPU number to revert back to the original one.
The MAC address should then be locked to the virtual server to make sure that if it is moved again, the CPU number does not change.

Second possible solution is to lock the new MAC address to the virtual server and then apply for a license migration.
This option can take a few days & can only be done during standard office hours, so is not recommended for a Live or production system.
 

Level of Complexity 

Easy

Applies to  

Product Version Build Environment Hardware
Kofax Communication Server All      

References

Add any references to other internal or external articles

 

Article # 3038034
  • Was this article helpful?