TC/Web Tiffy viewer certificate not updating automatically
Issue
The TC/Web Tiffy viewer certificate is unable to update automatically.
Cause
The URL for auto-updating the Tiffy Viewer Certificate has changed which prevents some current installations from updating it automatically.
Another cause could be that the KCS TC/Web server doesn't have direct internet access, in that case manually download and update the ach.jar & ach.cab files.
Solution
The new URL to download the cetificates is:
https://az32125.vo.msecnd.net/downlo...kcs/tcweb/2022
Please enter this new URL into the registry key:
..\TCWEB\CertificateAutoUpdateUrl
and start the certificate update by clicking the "update now" button when it appears after the login into TC/Web.
Usually it will update ach.jar and ach.cab automatically, but if you haven't assigned the correct write rights to ach.cab and ach.jar for the TC/Web user the update might fail.
Alternatively you could download both files with the following links:
https://az32125.vo.msecnd.net/downlo...b/2022/ach.jar
https://az32125.vo.msecnd.net/downlo...b/2022/ach.cab
Copy them manually into the TCWEB folder replacing the old files.
NOTE: can only be done by a user who has sufficient rights assigned, otherwise you cannot overwrite the old files
Just for info:
"version.xml" is also on the web, but does not need to be copied to the local TC/Web servers!
And don't forget to do a "iisreset" after updating the certificates, this needs to be done after manual or automatic update!
NOTE:
- In KCS version 10.3 the Tiffy viewer is replaced by Atalsoft web viever.
- The current Tiffy certificates are valid until July 13th 2022 which is the same date when KCS 10.2 is end of support.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Communication Server - TC/Web | 10.2.x | 3584, 4079 |