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Kofax

TCOSS failed, KCS cannot start, TCOSS unable to start process, KCS not running

Article # 3035889 - Page views: 22

Article # 3035889 - Page views: 22

Issue

KCS / Tcoss cannot start anymore because the tcoss.exe was deleted by anti virus software.

Cause

Several different Anti-Virus packages started to delete TCOSS.exe since the weekend of 9/10th November 2019.
The following Virus scanners have been reported to delete TCOSS.exe:
  • Trend Micro OfficeScan Agent
  • Trend Micro Deep security

The result is that TCOSS/KCS is not running anymore / unable to start.

The KCS monitor shows "TCOSS unable to start process - Restarting" warning followed by a "TCOSS failed" error.

Solution

To restore TCOSS.exe and prevent deletion in the future, please white-list the following KCS folders:
  • C:\MT
  • C:\TOPCALL
  • C:\TCOSS
Restore tcoss.exe afterwards from the Virus Scan quarantine.
 
If TCOSS,exe can't be restored, re-run the setup for "Make TCOSS" and copy the file from C:\MT\PRG to C:\TCOSS\SYSTEM.
Re-install any installed fixpacks.
If you've applied a fix that replaces tcoss.exe, apply it again.
 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
Kofax Communication Server all      

References

 

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