DocToPDF (Amyuni) produces PDF files with wrong paper size (A4 instead of US Letter or vice versa)
Issue
DocToPDF with Amyuni as Processor is used for converting a Word document to PDF. The result PDF document has a wrong paper size. E.g. the source Word document has A4 as paper size and the result PDF document has US Letter "11 as paper size.
Cause
This can be caused by 2 different things. Microsoft Word is limited to 255 forms and this can cause problems when more forms are installed on the system. A form is the equivalent of a paper type/size. When a lot of additional printer drivers are installed, you can have more than 255 forms. When you have more than 255 forms, some forms will not be available anymore in Microsoft Word such as A4 or US Letter.
Another cause is a known issue in Microsoft Word. Amyuni is a PDF Printer driver. When DocToPDF is used with Amyuni as processor, Microsoft Word opens the document and prints it to PDF file using the Amyuni PDF Printer driver. This means that Microsoft Word settings affect the PDF conversion. The Word setting "Scale Content for A4 or 8.5 x 11" paper sizes" can cause documents to be printed in a different paper size than expected. This setting is enabled by default for new Microsoft Word installations.
Solution
To confirm the problem is that the system has more than 255 forms, restart all Document Processors. When a Document Processor is started, it logs diagnostic information in the beginning of the log file.
- Open KCM Core Administrator and open the Servers Node (left hand side) and click on the machine name.
- Select a Document Processor (ITPDP [core_xx_x.x]#x ) and click Restart.
- Select the same Document Processor and click view log.
If this machine has too many forms, it will be logged as following.
14:52:31.694[0] Main thread: ************************************************************** 14:52:31.694[0] Main thread: * Found 264 forms installed on this system. * 14:52:31.694[0] Main thread: * * 14:52:31.694[0] Main thread: * Word is limited to 255 forms and can cause problems when * 14:52:31.694[0] Main thread: * documents are converted to PDF which are in the US Letter, * 14:52:31.694[0] Main thread: * US Legal, A4 or A3 predefined paper sizes. * 14:52:31.694[0] Main thread: * * 14:52:31.694[0] Main thread: * During the DocToPDF these documents could be resized by * 14:52:31.710[0] Main thread: * Word to an alternative paper size. * 14:52:31.710[0] Main thread: * * 14:52:31.710[0] Main thread: * Either remove printer drivers and/or forms to get below * 14:52:31.710[0] Main thread: * the limit of 255 forms, or add forms upto at least 265 * 14:52:31.710[0] Main thread: * to work around this problem for the predefined paper sizes * 14:52:31.710[0] Main thread: * noted above. * 14:52:31.710[0] Main thread: * * 14:52:31.710[0] Main thread: * Please refer to the Known Issues section of the ITP/Server * 14:52:31.710[0] Main thread: * manual for more details. * 14:52:31.710[0] Main thread: **************************************************************
In this example the machine has 264 forms. At least 10 forms must be removed to resolve the problem.
- Open print management (printmanagement.msc). If this snap-in is not available, then you have to install the Windows feature "Role Administration Tools -> Print and Document Services Tools".
- In the left pane open Printer Servers, open your machine and right click Forms.
- Here you can delete non-system forms. Forms which were added via the printer drivers. System Forms cannot be removed. Delete Forms until less than 255 Forms are available on Windows.
- Restart the Document Processors. In KCM Core Administrator go to menu File -> Restart KCM Core.
- Open KCM Core Administrator and open the Servers Node (left hand side) and click on the machine name.
- Select a Document Processor and click view log. Confirm that the warning is not logged anymore.
Microsoft Word setting ("Scale Content for A4 or 8.5 x 11")
To change the Word settings for Microsoft Word used by KCM:
- You need to be logged in with the same account as used by KCM
- Microsoft Word may not be already opened by this account. If Microsoft Word is still opened, the changed settings will not take effect and will be reverted.
- Login the machine with the same account as used for running the KCM services. You can see the account name via services.msc or Core Administrator.
- Open Core Administrator and stop all Document Processors. You could use menu File -> Stop KCM Core.
- Open task manager and kill any left-over winword.exe processes. As an alternative you can run "taskkill /F /IM winword.exe" (without quotes) from an elevated command prompt.
- Open Microft Word and go to File -> Options -> Advanced.
- De-select "Scale Content for A4 or 8.5 x 11" and click Ok for closing each dialog window and close Microsoft Word.
- Start all Document Processors again. You can do this in Core Administrator via menu File -> Start KCM Core.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Communications Manager | All versions | n/a | n/a | n/a |
Article # 3035759