FATAL ERROR DMN0161: TCP/IP error 10060 in function WSARecv
Issue
During document composition KCM reports the following error:
FATAL ERROR DMN0161: TCP/IP error 10060 in function <WSARecv>.
Cause
When the data manager tried to connect to the iSeries machine the Windows Server operating system reported an TCP/IP error. On the Microsoft website (link) all TCP/IP error codes are documented. The following information is provided by Microsoft:
WSAETIMEDOUT 10060 Connection timed out. A connection attempt failed because the connected party did not properly respond after a period of time, or the established connection failed because the connected host has failed to respond.
Windows reports there is a problem with the network connection to the iSeries machine.
Either the iSeries machine doesn't accept the connection, or something dropped the connection.
Solution
One possibility is that a corporate firewall drops the connection between the data manager and the ITPSRVHDM job on the iSeries machine. By default keep-alive is set to 2 hours on an iSeries machine for TCP connections. It is common that companies have aggressive network firewalls that drop inactive connections that have been idle for more than 1 hour.
The keep-alive interval can be lowered on the iSeries machine via the command
CHGTCPA TCPKEEPALV(xxxx)
Refer to the IBM website for more information (link).
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Communications Manager | n/a | n/a | iSeries DID | n/a |