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FATAL ERROR OOX2019: Office 16 is currently not supported

Article # 3035823 - Page views: 98

Issue

In KCM Designer you receive one of the following errors after editing a DOCX master template or rich text block:

REP0617: Parsing <<document>> for includes failed
REP0853: Conversion to idoc format failed

A template uses post-includes, KCM Core reports the following runtime error:

OOX2019: Office 16 is currently not supported.

 

Cause

For KCM 5.3 and older, this can be caused by a reference to a specific (unused) namespace in the document in question. A safety check implemented in KCM prevents this document from being converted, resulting in above error. 

There is also the general possibility that Repository Server is not able to convert the to idoc for another reason.

 

Solution

KCM 5.3 and older

Regarding the namespace issue, this was classified as a defect and was resolved in KCM versions 5.3.1 and above. To resolve this issue, update to KCM 5.3 and install service pack 1, or update to a newer KCM version altogether.

As an alternative to upgrading KCM to 5.3.1 or newer, you can also downgrade Microsoft Office back to a version that does not exhibit this issue. The last version that does not produce this error is the version from 2019 August 13, Version 1907 (Build 11901.20218). To downgrade office, please refer to this Microsoft article: https://support.microsoft.com/en-us/help/2770432/how-to-revert-to-an-earlier-version-of-office-2013-or-office-2016-clic

General issue on all KCM versions

It can also be that a general configuration issue can be the cause of this.

Please navigate to your CCM/KCM Work folder (default C:\CCM\Work\ or C:\KCM\Work\) and navigate to the itprep.ini of Repository Server, example

"C:\KCM\Work\5.5\Instance_01\designer\Config\itprep.ini"

Open the file and check that the TempPath and LogFile settings point to the correct folder, example:

TempPath=C:\KCM\Temp

LogPath=C:\KCM\Work\5.5\Instance_01\designer\Log\KCM\ITPMDK [designer_01_5.5]

If this was not correct, please change and then restart the KCM Repository Server service.

 

Level of Complexity 

Easy, Moderate

 

Applies to  

Product Version Build Environment Hardware
Kofax Communications Manager all versions n/a n/a n/a

 

 

Article # 3035823