Skip to main content
Kofax

DocToPDF (Amyuni) produces PDF files with low quality images

3023588

Symptoms

On the affected Document Processor(s), The DocToPDF command has been used at least once with the parameter ColorProfile("..\myColorProfile.icc") and ProducePDFX(True). All PDF documents produced with Amyuni have low quality images. These images appear to have JPEG-like compression artifacts.

Cause

This is a known problem of the Amyuni PDF Converter. When a color profile is set, Amyuni will convert images to CMYK. When Automatic Image Compression is enabled, this will lead to degraded image quality. When a color profile is set by Amyuni, this is applied to the Amyuni PDF printer driver. This color profile is not removed after conversion. This means that subsequent PDF conversions from now on, regardless whether the colorprofile parameter is provided to the DocToPDF command.

Resolution

Automatic Image Compression can be disabled to produce PDF documents with a color profile applied and good image quality. This will result in larger PDF files, since no image compression is applied.

DocToPDF
  Src(source )
  Dest(dest )
  AutomaticImageCompression(False)
  Colorprofile("..\myColorProfile.icc")
  ProducePDFX(True);

To remove the color profile assigned to the Amyuni PDF Printer driver, you can reinstall the Document Processor. Reinstalling a Document Processor also reinstalls the associated Amyuni PDF Printer Driver.
1). Open Core Administrator.
2). Open the node Servers  and click on the machine name.
3). For each Document Processor, select the Document Processor (ITPDP[core_xx_x.x]#x) and click 'Remove DP'.
4). Click 'Add DP's' and add the same amount of Document Processors again.

 

Applies to:  

Product Version
KCM 5.3 and higher
KCCM 5.2 and lower

 

 

  • Was this article helpful?