Resources from 'proxy' location on the KCM server are unavailable
Issue
KCM has been installed as a cloud setup. One machine is configured as a Remote Contract Manager ( Deploy!PredefinedSetup=ContractManagerOnly) and one or more other machines as instance machines. For the ComposerUI for HTML5 integration, you make use of of the proxy location on the KCM Contract Manager Server. When using the ComposerUI integration you receive an HTTP 404 error when these resources are accessed. E.g.:
https://<host contract manager>/proxy/ccmcomposerui.js
Cause
This is caused by a defect in the installer. When a ContractManagerOnly setup is installed, the files exposed via the proxy are not installed. As a result these files are not available for web applications that integrate ComposerUI for HTML5.
Solution
This bug is fixed in KCM 5.4
There are two different workarounds.
A) Use a different Predefined Setup option that also installs an instance and remove the instance afterwards.
1. Install KCM where you omit the parameter Deploy!PredefinedSetup and where you include the parameter OutputManagement!Install=false.
2. After installation remove the instance via the PowerShell script RemoveInstance.ps1. The script is located in the folder "..\KCM\Programs\<version>\Management\".
B) Copy over the missing files from the installation media to the proxy folder.
1). Copy the contents of ..\InstallServer\Software\ITPi\proxy\ to <Tomcat>\instance-CCMRuntime-N.N\webapps-CM\proxy\.
2). Restart the service Apache Tomcat CCMRuntime instance N.N.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Communications Manager | 5.3 and earlier | n/a | n/a | n/a |
Article # 3035790