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Storage limit exceeded for data queue WEANSWER in WINPGM3

Article # 3035629 - Page views: 246

Issue

WindowsEnabler clients cannot connect to WindowsEnabler/400 daemon. In the job log of WindowsEnabler Daemon (WECM) you can see the following error:

Message  . . . . :   Storage limit exceeded for data queue WEANSWER in WINPGM3.
Cause . . . . . :   Data queue WEANSWER in WINPGM3 would exceed its maximum storage with this message.
Recovery  . . . :   Since messages can be variable in length, it is possible that a smaller message could be sent to the data queue. Other actions are to clear the data queue or receive one or more messages for the data queue to release part of the data area.

This error message can also occur for data queues WEREQUEST or WETCP.

 

Cause

The data queue WEANSWER/WEREQUEST/WETCP has reached its storage limit. 

 

Solution

You can resolve this error by recreating all data queues. To do this via commands:

  1.  <WE_LIB>/ENDWETCP
  2. <WE_LIB>/DLTWEDTQS deletes the WindowsEnabler/400 internal dataqueues.
  3. <WE_LIB>/CRTWEDTQS creates the WindowsEnabler/400 internal dataqueues.
  4. <WE_LIB>/STRWETCP

Via the configuration menu

  1. <WE_LIB>/WECFG
  2. Option 32. Stop daemon.
  3. Option 22. Remove configuration objects.
  4. Option 21. Create Configuration objects.
  5. Option 31. Start deamon.

The default library (WE_LIB) is WINPGM3.

 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
Kofax Communications Manager all versions n/a iSeries n/a

 

 

Article # 3035629