WindowsEnabler clients fail to connect to WindowsEnabler Daemon after keep-alive has been enabled
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Issue
WindowsEnabler clients cannot connect to WindowsEnabler/400 daemon when the daemon is started with KEEPALIVE enabled. In the WindowsEnabler client log you see the following error:
Host closed connection. Error code: 0
In WECM job log you see the following error:
MCH1210 Escape 40 16/05/19 09:20:46.496964 WECM WINPGM3 *STMT WECM WINPGM3 *STMT From module . . . . . . . . : WECM From procedure . . . . . . : ReceiveFromClient Statement . . . . . . . . . : 13 To module . . . . . . . . . : WECM To procedure . . . . . . . : ReceiveFromClient Statement . . . . . . . . . : 13 Message . . . . : Receiver value too small to hold result.
In WECMD job log you see the following error:
CPF9898 Diagnostic 40 16/05/19 09:19:20.827433 WECMD WINPGM3 *STMT QCMD QSYS 01C8 From module . . . . . . . . : MESSAGES From procedure . . . . . . : Diagnostic Statement . . . . . . . . . : 4 Message . . . . : Bind of socket failed. Errno: 3420. Cause . . . . . : This message is used by application programs as a general escape message.
Cause
You are using a keep-alive value that is larger than 16 (minutes). WindowsEnabler/400 does not support a keep-alive setting larger than 16.
Solution
Use a keep-alive setting of 16 or lower. For example:
WINPGM3\STRWETCP KEEPALIVE( 2 )
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Communications Manager | all versions | n/a | iSeries | n/a |
Article # 3035383