Trust GlobalSign-validated Signatures in Kofax PowerPDF
Article # 3048312 - Page views: 120
Issue
When signing a document with the help of Kofax SignDoc Cloud, the signature might be shown as problematic when viewing the document with Kofax PowerPDF.
The message that is shown states "This document is signed. At least one signature has problems."
Cause
The GlobalSign Root Certificate is not installed and trusted by default.
Solution
- Navigate to https://support.globalsign.com/ca-certificates/root-certificates/globalsign-root-certificates and download the certificate "GlobalSign Document Signing Root R45".
- Open the window for "Trusted Identities":
- Click on the button "Add ID..." and add the downloaded certificate (if not done automatically, set it as "trusted root").
- Close the window and open the Kofax PowerPDF Options (Menu Item "File" -> "Options").
- Navigate to "Signatures" below the "Signatures" entry and click "More..." butten for "Verification":
- At the bottom, click the checkbox for "Validating Certified Documents"
- Click the OK button to save these settings.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax PowerPDF Kofax SignDoc Cloud |
n/a |