Skip to main content
Kofax

Trust GlobalSign-validated Signatures in Kofax PowerPDF

Article # 3048312 - Page views: 120

Issue

When signing a document with the help of Kofax SignDoc Cloud, the signature might be shown as problematic when viewing the document with Kofax PowerPDF.

The message that is shown states "This document is signed. At least one signature has problems."

clipboard_e193f3545b3687bac79e9b75a5a75f11b.png

Cause

The GlobalSign Root Certificate is not installed and trusted by default. 

 

Solution

  1. Navigate to https://support.globalsign.com/ca-certificates/root-certificates/globalsign-root-certificates and download the certificate "GlobalSign Document Signing Root R45".
  2. Open the window for "Trusted Identities":
    clipboard_e84b618d4c9c206314e8d706ad5c9bd9a.png
  3. Click on the button "Add ID..." and add the downloaded certificate (if not done automatically, set it as "trusted root").
  4. Close the window and open the Kofax PowerPDF Options (Menu Item "File" -> "Options").
  5. Navigate to "Signatures" below the "Signatures" entry and click "More..." butten for "Verification": 
    clipboard_ebd91ea46d71341b34946f89224dfeac3.png
  6. At the bottom, click the checkbox for "Validating Certified Documents"
    clipboard_ebabf0cc33f4a9bb6b85f508c82516b61.png
  7. Click the OK button to save these settings.

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
Kofax PowerPDF
Kofax SignDoc Cloud
n/a      

 

 

Article # 3048312
  • Was this article helpful?