Skip to main content
Kofax

IIS errors on first use of CCM Core Web Services Interface ASP.NET

Symptoms

You are using Kofax CCM 5.1.0 or newer. After installing CCM Core Web Services Interface ASP.NET, you receive the following IIS error when retrieving the WSDL

  • Configuration error: Could not load file or assembly 'itpserver' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

clipboard_e639b1673378233ffd71e75665e6e6e04.png

Cause

From Kofax CCM 5.1.0, CCM Core Web Services Interface ASP.NET has switched from ASP.NET 3.5 to ASP.NET 4.X. You are using Classic .NET AppPool which uses ASP.NET 3.5 while ASP.NET 4.X is required. 

Resolution

Switch to ASP.NET 4.X to resolve the error. In Kofax CCM 5.1.0 and higher, the requirements for CCM Core Web Services Interface ASP.NET are:

  • IIS 7 or higher (Server Role)
  • Microsoft .NET Framework 4.X (Feature)
  • ASP.NET 4.X (Feature under Server Role Web Server (IIS) -> Web Server -> Application Development)

After the above requirements are met, switch to ASP.NET 4.X using the following steps:

  1. Open Internet Information Services (IIS) Manager.
  2. Select the 'CCM Core Web Services Interface ASP.NET' application (itpserver) and go to Basic Settings.
  3. Switch the used Application pool from 'Classic .NET AppPool' to '.NET v4.5 Classic'

clipboard_e2e005a0df994b683cf8153e9f012aaf5.png