AutoStore - OCR and OPBarcode Exiting Component (0x80070005) issue
Problem Statement:
Using AutoStore 6 and AutoStore 7, the OmniPage OCR and OPBarcode component which outputs an error code 0x80070005 have been recently reported after performing some Windows Updates on the server.
OCR component information from status monitor:
OPBarcode component information in status monitor:
2018/01/08 09:19:36:80 07336 [STT] OPBarcode: Exiting Component (0x80070005).
Cause:
The following Microsoft Windows Updates released in January 2018 appears to be related to the error.
KB4056888 (Windows 10 Version 1511)
KB4056890 (Windows 10 Version 1607)
KB4056891 (Windows 10 Version 1703)
KB4056892 (Windows 10 Version 1709)
KB4056895 (Windows 8.1,Windows Server 2012 R2 Service Pack 1)
KB4056896 (Windows Server 2012 R2 Service Pack 1)
KB4056897 (Windows Server 2008 R2 Service Pack 1, Windows 7 Service Pack 1)
KB4056898 (Windows 8.1, Windows Server 2012 R2 Standard)
KB4056899 (Windows Server 2012 Standard)
KB4058702 (Windows 10 Version 1709)
KB4073291 (Windows 10 Version 1709)
Resolution:
Microsoft released updates which resolve the issue.
The update is available via Windows Software Updates > Optional Updates.
Windows Server 2012 R2 Standard - install KB4057401 (see example below)
Windows Server 2012 Standard - install KB4057402
Windows Server 2008 R2 Service Pack 1 - install KB4057400
Windows 10 Version 1511 - install KB4075200
Windows 10 Version 1607 - install KB4057142
Windows 10 Version 1703 - install KB4057144
Windows 10 Version 1709 - install KB4058258
Windows 8.1 - install KB4057401 (see example below)
Windows 7 Service Pack 1- KB4057400
Example: KB4057401 which is fix for KB4056895 solves the problem for Windows 8.1 and Windows Server 2012 R2 Standard (see screenshot from Microsoft below). (Side note: The German Microsoft KB pages have not yet been updated with this information).
Attachments: