Skip to main content
Kofax

Autostore 7 SP5 Patch 1 and above: Not able to register HP OXPd v1.6 devices

Article # 3016408 - Page views: 747

Problem Statement:

During device registration an error occurs such like

Error (Attempts 0): OXPd.Common.TranslatorException: Error accessing DiscoveryTree.xml ---> System.Net.WebException: The underlying connection was closed: The connection was closed unexpectedly.

at System.Net.HttpWebRequest.GetResponse()

at OXPd.Utils.Http.GetUriAsString(String hostname, Boolean useHttps, String uriPath)

at OXPd.Domain.ServiceDiscovery.DiscoveryTreeTranslator.GetOXPdDiscoveryTree(String hostname, Int16 port, Boolean useHttps)

--- End of inner exception stack trace ---

at OXPd.Domain.ServiceDiscovery.DiscoveryTreeTranslator.GetOXPdDiscoveryTree(String hostname, Int16 port, Boolean useHttps)

at HpOXPd16Capture.OXPd16SetupAgent.RemoveAllAppsFromMfp(Device mfp)

or

Error (Attempts 0): The http://www.hp.com/schemas/imaging/OX...etUIAttributes cannot be processed at the receiver

Cause:

This error is caused by incompatibility of the supported OXPd version. The Autostore server doesn't support the OXPd version of the device. Since AS7 SP5 Patch 1, the OXPd version of the HP OXPd component has been upgraded to support v1.7 and no longer supports v1.6 devices. 

Currently known devices which cannot be upgraded to OXPd 1.7 (subject to change):

  • HP ScanJet 7000n
  • HP Digital Sender Flow 8500 fn1

Resolution:

These devices can only be used with AS7 SP5 (without patch) or below. If a device not listed here causes the same error, the latest firmware must be installed on the MFP. FutureSmart 4 or newer is required.