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ControlSuite: Delay to View Job list (if the servers have no Internet access)

Article # 3039473 - Page views: 372

Problem: 

Sometimes there can be a delay when attempting to view the jobs list on the device. After logging into the device, the jobs are not there however if the user logs in the second time, the jobs are seen. This can happen on ControlSuite servers which do not have internet access. 

Cause:

This is caused by a delay in the TLS handshake between Print Job Management (PJM) and Security Framework (SFS). There can be a 15 second delay in this call. 

During this process the Windows Certificate Trust List (CTL) updater engine is trying to update its root certificates for the PJM server and as there is no internet access on this server, this request fails and can cause a delay.

Solution: 

To resolve this, the CTL updater engine needs to be stopped from trying to update its certificates every time communication is made between SFS and PJM 

  1. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\SystemCertificates\AuthRoot
  2. Create a backup of this key
  3. Create the following DWORD registry values under the key
  4. "EnableDisallowedCertAutoUpdate"=dword:00000000
  5. "DisableRootAutoUpdate"=dword:00000001
  6. Save and then reboot the server and then test

Further information can be found at Issues when ControlSuite server is not internet connected - Kofax

Applies to:  

Product Version
ControlSuite  All Versions

 

Article # 3039473
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