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CopitrakDesktopSuite (CD3) does not have input focus

Article # 3041898 - Page views: 20

Issue

When a user prints a document, the CopitrakDesktopSuite (CD3) billing popup interface does not have input focus. This causes input text to write to document in background, behind the Copitrak interface.

 

Cause

This is by design of Microsoft Windows.

More Information
This behaviour is controlled by the registry setting "ForegroundLockTimeout".

  • This is specifies the length of time (following user input) during which the system keeps applications from moving into the foreground.


In other words (under certain circumstances) Windows waits (by default for 200 seconds) before moving applications (like Office Applications) into the foreground where CopitrakDesktop always has focus.

 

Solution

Work around (a) User workflow:

Click in the CopitrakDesktop interface (to bring input cursor to the foreground).

Work around (b) Windows Registry:

WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to re-install Windows to correct them. 

Modify the end user's Windows profile so that Applications take the input focus instantly.

  • This is achieved by modifying the value of 'ForegroundLockTimeout' to be set with value of zero (0).

Steps:

There are several possible methods to modify registry keys for end users, for example:

  1. (a) Via a script/batch-file
  2. (b) Manually
  3. (c) Via a Microsoft Windows Group Policy Object (GPO)
Please consult with your I.T. department, to deploy the needed changes.

Details

HKEY_CURRENT_USER\Control Panel\Desktop

Search for an entry 'ForegroundLockTimeout'

  • If the entry exists, then change its value to 0 (zero) [Default is 30d40]

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Level of Complexity 

Advanced

 

Applies to  

Product Version Build Environment Hardware
CopitrakDesktop 3.0      

References

Add any references to other internal or external articles

 

Article # 3041898