DRS Issue with Ricoh SOP Deployment
Problem:
Getting "Unknown error. Please check Logs folder for details" message almost instantly when deploying the Ricoh SOP embedded (Return Code 500).
No matter what Action was selected to push to the device or what version of PCC5 was used the same error instantly returned by DRS.
When looking at the PluginError.log the following message is seen after each action
Message: Ricoh -> Ricoh Initialization Failed: Can't get path to jvm.dll from RAGetJVMDll.
Cause:
This issue could happen if Amazon Corretto x86 was not installed
Solution:
Install amazon-corretto-8.292.10.1-windows-x86 (should be in the prerequisites folder of the ControlSuite offline installer, or you can download it from the internet) and restart DRS service.
If you still having issues deploying Ricoh SOP then please reffer to the following KB: Ricoh PCC5.1: How to diagnose Device Registration Service (DRS) when deploying to the MFD
Applies to:
Product | Version |
---|---|
ControlSuite | 1.2 |
DRS | 8.2 |