Skip to main content
Kofax

Upgrading Oracle Java to a later version causes Ricoh Devices to no longer communicate with DRS

3030455

Question / Problem: 

After upgrading Oracle Java to version 8u261 or later, the Device Registration Service no longer is able to communicate with Rioch MFDs. The Plugin Error log reports the following

Error Message : ERROR in LoadJNIFunctions. Failed to load Java dll.

Answer / Solution: 

As of Oracle Java 8u261 and Later, the Java Platform no longer uses older versions of the C++ Runtime. If the C++ Runtime version 2010 is installed, install C++ Runtime version 2015 or later.

Applies to:  

Product Version
Device Registration Service 7.x
  8.x

 

 

  • Was this article helpful?