The Web Deposit database seems to be corrupt. Please contact your Equitrac Express administrator
Article # 3015453 - Page views: 282
Problem Statement:
After a "Repair" process is executed with the installer, the Web Deposit is unusable; it shows an error message "The Web Deposit database seems to be corrupt. Please contact your Equitrac Express administrator".
Cause:
The "Repair" process is resetting the connection string of the Web Deposit.
Resolution:
Manually edit the web.config file and set the database servername and instance for the "Data Source" value in the connection string.
- Locate the "
\Areas\WebDeposit\web.config" configuration file. NOTE: By default, the file is located in "C:\Program Files\Equitrac\WebClient\Areas\WebDeposit\web.config". - Open the configuration file in a text editor (e.g. Notepad).
- Find the "
\ " element and then its child element where the "name" attribute is "EQWebDeposit". - Set the "data source=" value of the "connectionString" attribute to the server and instance name of the SQL server where the "EQWebDeposit" database is created.
Example:
- Set the authentication method for the database by modifying the "connectionString" attribute: • If a fixed user is used, append ";User ID=...;Password=...;" to the end of the attribute value. • If Windows authentication is used, make sure that "User ID=ナ" and "Password=ナ" values do not exist.
- Restart the "Equitrac" application pool in IIS.
Note: This issue is expected to be fixed in a future release.