Skip to main content
Kofax

Equitrac: Security and system hardening regarding TLS

Information:

For security reasons, there is interest to use higher levels of encryption.  The following information may be helpful when hardening Equitrac systems.

  • Equitrac Office/Express 5.5, 5.6, and 5.7 may use TLS 1.0, 1.1, and 1.2 when communicating between services and with devices however device specific limitations and Windows OS settings will determine the level used.
  • All Equitrac 5.x versions require TLS 1.0 to install and function. Disabling TLS 1.0 and/or TLS 1.1 is not officially supported.
  • Under some circumstances, it is possible to configure environments to use only TLS 1.1 or only TLS 1.2. This, however, is not officially supported with EO/EE 5.x. 
  • Equitrac 6 and ControlSuite support hardening to TLS 1.2 at the server level for communications between Equitrac components.
  • Kofax considers software security to be a high priority, so security will be continually improved with newer software releases.