EO/EE: An IPPClient user is seen in reports when performing IPP printing through Equitrac on Xerox devices
Problem Statement
When choosing IPP protocol in the output options of the physical device and tracking through JBA (print), the user and account IPPClient is seen in Equitrac reports.
JBA print data pulled by Equitrac 'Xerox EIP, JBA' embedded from the device:
2782 1 2782
Wed May 25 18:42:55 2011
"job:583"
accounting-information = 65 71 75 69 74 72 61 63 22 45 51 2d 33 71 39 6c 31 76 35 32 70 75 38 70 72 6f 67 65 64 34 69 74 31 34 6d 30 33 38
accounting-information-avp = "XRX_ACCTID,EQ-3q9l1v52pu8proged4it14m038"
accounting-information-avp = "XRX_USERID,equitrac"
jba-device-name = "3905797840"
job-identifier = "job:583"
IPPClient"
completion-time = 20170516101041
job-name = http://WC7530/583
finishing = "none"
job-type = print
jobtype-detail = "mark-normal"
lakes-number-of-images = 1
job-copies-completed = 1
media-sheets-completed = 1
jba-media-block-1 = "standard, white, 210 X 297, 1, , 0, 1"
jba-media-other-pages = 0
jba-total-simplex-sheets = 1
jba-total-duplex-sheets = 0
jba-completed-reasons = "completed-normal"
job-validated = TRUE
job-owner-domain = "testlab.net"
system-job-identifier = "job:583"
system-job-type = "Print"
Xerox MFP display:
Job Status - Completed Jobs:
# Owner Name Status
001 IPPClient http://WC7530/583 Completed
Equitrac Detailed Report:
WC7530-Xerox
Date User Account Type Description Details Pages Cost
16/5/2017 10:41 AM ippclient ippclient user http://WC7530/583 1 x A4 1 0.30
Cause
This is due to the way that Equitrac is outputting the job to the device via the IPP (and IPPS) protocol.
When printing via the IPP protocol, the device reports in print JBA the user as being IPPClient and also the document name is not used; job will show something like 'http://
Because of this, Equitrac has no method to obtain the correct tracking information from the device.
Resolution
If IPP is the required method of printing through Equitrac on Xerox devices and accurate tracking information is required, the recommended solution would be to initialize the device using Xerox ECSP.
ECSP uses a consolidation method of tracking which provides an accurate form of reporting.