Skip to main content
Kofax

Equitrac: Kofax Ethernet Card Reader Discovery Fails

Problem Statement

In the Equitrac System Manager, the Kofax Ethernet Card Reader discovery fails when trying to discover card readers on a remote server (i.e. the selected server running DCS in the Card reader discovery window is not the server System Manager is running on). The error message is:

An error was encountered when attempting to submit a service request. Please ensure the services are running and there are no network connectivity issues.

Cause

  • The Device Control Service port (TCP port 2943) may be blocked on the remote server
  • The Kofax Device Control Service on the remote server may not be running

Possible Resolution

  1. Check that TCP port 2943 is open on the remote server, and communication is possible.
  2. Check that the Kofax Device Control Service on the remote server is properly installed and running.
  3. Use System Manager on the server running DCS to discover the card readers