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EP5 custom report filter results in "No Data "

EP5 custom report filter results in "No Data "

Problem Statement:

When filtering a report in the WebClient using the Custom Filter, and filtering in Device Name, the results show that there is No Data found. When checking the Transaction Editor, there is verifiable data that should be in the report.

Cause:

Syntax error when filtering on the device name.  Filters are case sensitive. 

Resolution:

When entering the description of the device name, the name of the device has to be exact. If the device is say, C-PRIN3931A (Color), you cannot use

C-PRIN3931A (COLOR) or C-PRIN3931A(Color).