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Transactions are not being recorded and data cannot be exported from Equitrac Professional after changing the name of the Equitrac Professional server

Transactions are not being recorded and data cannot be exported from Equitrac Professional after changing the name of the Equitrac Professional server

Problem Statement:

After changing the Equitrac Professional server's name, the database cannot be connected to. Transactions on any connected Equitrac device cannot be written to the server and data cannot be exported from Equitrac Professional.

Cause:

The Equitrac Professional server is attempting to connect to the database using the original server's name.

Resolution:

Note: This resolution is for Equitrac Professional servers that have Microsoft SQL Server Express installed on it.

1. On the Equitrac Professional server, go to Start > Run > REGEDIT

2. Nuance Communications, Inc. strongly recommends that a full backup of the Windows Registry be made. Nuance Communications, Inc. provides the steps outlined to modify the Windows Registry "as is." Should an issue arise after modifying the registry, please contact Microsoft Corporation for assistance.

3. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Equitrac\CAS\database

4. Update the "Data Source" in the connectionString by replacing the old server name with a period '.' if the SQL server is local or the new SQL Server name and instance.

For example the connectionString would be changed from Data Source=ServerName\SQLExpress;user id=eqcas;Password=eqcas to Data Source=.\SQLExpress;user id=eqcas;Password=eqcas

5. Click OK

6. Close Registry Editor

7. Restart all EQ services

NOTE: EP5 server name change also requires that the EP5 licenses must also be reset and re-registered (see KB article 17767 for the appropriate steps).