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Output Manager: Legacy client encounters "error 13 : Cannot Get Special Device ID" message

Article # 3017002 - Page views: 400

Problem Statement:

After relocating, replacing, or servicing a Ricoh MFD that is using the Ricoh ESA client with an Output Manager or Output Manager/Autostore integration, the message "Error 13 - Cannot get special device ID" may appear on the MFD when a user attempts to login.

Cause:

This can be caused if Output Manager is unable to associate the embedded client with a device record in Output Manager.

For example, if the device is physically moved or renamed, there may be a legacy record in OM that has the old IP, name and Mac Address, this message can occur. This can also occur if the MFD had undergone maintenance such as replacing the NIC or mainboard.

Resolution:

To resolve this error, the record in Output Manager must match the settings for the device. The easiest method is to recreate the device in Output Manager.

Part 1 - Remove the old device record from Output Manager

  1. Launch the Output Manager Console
  2. Navigate to the Destination section, and remove the Destination related to the MFD in question.
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    Note: If you get a message saying that it cannot be deleted, this can be caused by several things:

    a) The destination currently has documents associated to it in the Spooled/Retained tabs.
    b) There is a Business Rule that is referencing the destination
    c) There is a Source that is referencing the Destination

    The Message Console can provide you further details on what is preventing you from removing the Destination.
  3. Navigate to the Devices section and locate the device in the tree view on the left side
  4. Right click the device and select "Demote Device"
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    Note: You will need to do this from the tree view on the left. If you do this from the list on the right-hand side, you will not get the option to demote the device.
  5. Navigate to Administration > Manage Devices and locate the device under the Unused Devices tab. Check the device, and press the Delete button near the bottom right.
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Part 2 - Recreate the device in Output Manager

There are two methods that you can use to recreate the device.

Method 1: Manually add the device

  1. Navigate to Devices, right click and select "New Device"
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  2. Populate the dialog that is presented with the MFD information
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  3. Right click the new device, and select "Create Destination"
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  4. Select Socket for the destination type
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Method 2: Auto detect and promote

  1. Navigate to Administration > Manage Devices
  2. Select your appropriate Output Manager server from the top selection and press the "Detect Device" button
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  3. In the "Add single IP range" section, enter either the IP or the range where the device is located.
    For example: If the device has an IP address of 192.168.0.10, you can either enter the entire subnet, (e.g. 192.168.0.1 - 192.168.0.255), a narrow range (e.g. 192.168.0.1 - 192.168.0.12), or the explicit IP address (e.g. 192.168.0.10 - 192.168.0.10)
  4. Ensure that the range is checked and select OK.
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  5. After a few moments, the device should appear in the "Unused Devices" tab with the updated device information
  6. Check the device, and select the "Promote to OM" button.
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  7. When prompted to create a destination, select Yes and choose Socket as the connection type.
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Part 3 - Enable the device for the Embedded client

  1. Under Devices, locate the newly created device, right click it, and select Configure Device.
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  2. Under the Device Details tab, select Ricoh for the Secure Release type, and check the Embedded Client/Unified Client checkmark and select OK
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