ShareScan: Every device that you use with eCopy ShareScan requires a valid license
Problem Statement:
When attempting to add a device in the eCopy Sharescan Administration Console a message appears indicating "Every device that you use with eCopy ShareScan requires a valid license. You can add a License Key valid for use with an eCopy-enabled device." This message appears even when a valid license key is added to the Administration Console.
There are multiple known causes of this conflict with differing resolutions.
Background:
Review the following:
- In the Licensing tab in the ShareScan Administration console, select ShareScan Device Canon and/or ShareScan Device Universal from the Feature name drop down.
- Record the quantities of each device type that are allowed by licensing and the quantity used. If the quantity of licenses available for use or the vendor encoding is not per expectations please see Cause 1, below.
- If using a ScanFront device please see Cause 2, below.
- If the above issues are not occurring and/or there is an indication that the host name of the eCopy Administration Console PC has been changed please see Cause 3, below.
Cause 1:
The quantity of licenses available for use with the vendor type has been exceeded.
This may be due to:
- A ShareScan device license has not been added to the ShareScan Administration Console- please add the ShareScan license to the administration console. If a license has been added but does not have the Scan Device feature, please create a customer service support ticket.
- An incorrectly encoded key was provided - please create a customer service support ticket.
- A device in the environment has been replaced however the device was not removed from the administration console. - Please remove all devices not in the customer environment from the ShareScan Administration console to ensure that the licenses have been released for use.
- The ShareScan Administration Console may also have been upgraded (such as from 5.1 to 5.2) and there remains a copy of the old manager present showing the same IP but the old version number and which has the same device associated with it. Please use ShareScan Troubleshooter to remove the extra manager data.
Cause 2:
The license was downloaded from the Nuance Activation server prior to the release of ScanFront for 5.x (i.e. in or before 2014). This should now be rare. To resolve this issue please delete the license from the administration console and re-add the license using the . Once the file is loaded into the Administration Console, automatic activation can occur.
Cause 3:
This issue could occur in older versions of eCopy ShareScan when the name of the computer hosting the eCopy software has been changed,
Resolution:
- Open up the Sharescan Administration console
- On the "Home" tab, click on the Remote Management icon. (the previous PC name will be listed here including IP address )
- Double click on the old PC name and IP. The system will prompt to connect to that Sharescan Manager. Select "YES"
- The Administration console will now be connected to the previously named Sharescan Manager
- Select the device tab and then right click on the physical device and select delete.
- Confirm deletion of the device.
- In the Home Ribbon > licensing menu, select the license report button to backup the licensing data
- Select Remove option and delete the current licenses
- Click on Home Ribbon> Remote Management again and double click on the Sharescan Manager reference with the current hostname and IP address.
- Once connected to the current Sharescan manager, click on the devices tab, right click on the physical device and click on delete. Confirm the deletion.
- Select the Home Ribbon> licensing > Remove button to delete the current active licenses
- Close out of the administration console ensuring that the system tray icon is exited.
- Go to Start> Run > and type services.msc to open the Windows services menu. Restart the Sharescan Manager & ShareScan Agent services.
- Reopen the Sharescan administration console.
- Open the Home Ribbon> Licensing tab and select "Load License" form to re-add the licenses.
- Add the devices using the Home Ribbon > Add Device form (NOTE: for ScanStation the device is auto-populated however must be reconfigured)
- Configure the device per customer requirements and test functionality.