Skip to main content
Kofax

MarkView Viewer fix to resolve performance problem or image load issue

3023232

Question / Problem: 

Due to a product defects (1467544, 1467546), the MarkView Viewer may not load, maybe slow to load the first time, and/or may show an error, such as:

"Error: [Ext.getBody] document.body does not yet exist" 

Additionally - it may only impact IE, and it also may only impact the first time a document is loaded. Refreshing the viewer or attempting to load the document a second time may work fine.

Answer / Solution: 

This issue is resolved via the MarkView 10.1.0.3 Fix Pack. All customers on MarkView 10.1, should apply the latest MarkView 10.1 Fix Pack as it includes this fix.

Latest 10.1 Fix Pack is available here.

Note: Fix Packs are cumulative, so applying the latest Fix Pack will ensure you get all of the fixes in the current and previous Fix Packs.

As always Kofax recommends applying in Non-Production, where proper testing can be conducted, prior to making any changes to Production.

 

How to verify if the fix is deployed:

  1. Open the MarkView Viewer.
  2. Right-click on the page and select Inspect element in the menu or press the F12 button (The Developer Tools window appears).
  3. Open the DOM Explorer tab.
  4. Locate the script tag with id set to the "microloader". It should be right under the body tag. Example: article_viewer_hot_fix_example_verify.png
  5. If you do not see such the script tag in the body, please, verify the header tag. If it is in the header tag, the fix is not deployed.

Applies to:  

Product Version
MarkView for Oracle 10.1.0.2 and below