Update Oasys Sequence number in Optitrade Confirm
Issue
How to update Oasys Reference number in Optitrade Confirm (OC)?
Cause
The oasys reference numbers generated in OC gets recycled approximately every year. If Database archiving is not in place or if archiving process has been missed, then it is vital to update the oasys reference / sequence numbers for all BROKER BIC's in Party management table.
NOTE: Please inform Optitrade Tech Support before updating Reference numbers.
Solution
Below are the Steps:
1. Stop all the ‘Optitrade Confirm’ services, except ‘Optitrade Confirm 05 CTM adapter’.
2. Click on ‘Party Management’ icon to update the reference number for each BROKER BIC’s. All the entries in ‘Reference Information’ need to be updated.
The ‘Acronym Number’ should be UNIQUE.
2a. Select the BROKER BIC and Click on ‘Modify’ button.
2b. Click on the ‘Reference Information’ button and then click ‘OK’.
2c. The acronym number has to be modified for each entry listed in ‘Reference Information’ tab.
2d. Select ‘BACW’ flow and click on ‘Modify’ button. Update the ‘acronym number’ which should be unique.
Update the ‘sequence number’ to ‘1’. Click ‘OK’ to submit.
The ‘acronym number’ is updated which is visible after clicking OK.
2e. Repeat the above step for other entries – ‘ACWF’ and ‘SWFT’ . Click on to submit. Then Click ‘OK’.
2f. If DUAL Authorization is in place, follow below steps else proceed to point number ‘3’.
After submission, the update has to be approved via security Manager. Click on ‘OK’ and Exit the ‘Party Management’ table.
2g. Navigate to ‘security Manager’ and click on ‘Party Records’. Records awaiting for approval are listed.
2h. Hover on the green arrow and click on ‘Approve Record’. Then review the information and click on ‘Approve’.
2i. Click on ‘OK’ and the record is no more listed in ‘Party records’ as it has been approved.
2j. The icon near the entry is gone after approval. Click on the ‘Reference Information’ to verify if the updates are reflected.
3. Repeat the above process for all BROKER BICs (inclusive of all entries within ‘reference Information’).
4. Restart all OC services.
If you have further questions or need assistance in updating Oasys Ref numbers, please contact Optitrade Tech Support via the Kofax Support Portal.
Level of Complexity
High
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Kofax Optitrade Confirm | OC 5.x+ |