Skip to main content
Kofax

What TLS version is required to connect to AP Essentials?

Article # 3030887 - Page views: 245

Issue

What TLS version is required to connect to AP Essentials (formerly ReadSoft Online)?

 

Solution

There are several methods which can be used to establish connections to Kofax AP Essentials:

  • User Interface via a Web browser
  • AP Essentials connect utility
  • AP Essentials API
  • ERP connections into AP Essentials via Target System Integrations


Currently, for each of these methods, AP Essentials allows for TLS 1.0/1.1/1.2 connections. However, in the very near future, Kofax AP Essentials will remove the ability to connect via TLS 1.0/1.1 and require all connections to use TLS 1.2.

Connecting to the UI via a web browser:
Please make sure your Web Browser supports TLS 1.2 connections.   Please see the article "Enabling TLS in your web browser" referenced below for additional information.

AP Essentials Connect:
Please make sure the version of AP Essentials Connect installed on your machine is greater than or equal to version 10.4.7451.  Please see the "Upgrading AP Essentials Connect to support TLS 1.2" KB article referenced below for additional information.

AP Essentials API:
For custom code developed using the API, please contact your Partner or third-party developer to ensure your custom code utilizes TLS 1.2.

Target System Integrations:
For any of the Target System integrations, such as Dynamics NAV/BC365, Dynamics AX, Dynamics 365 F&O, NetSuite, Oracle Financials Cloud, etc... please contact the ERP provider (Microsoft, Oracle, etc..) to assist with any configurations necessary within the ERP to ensure that all outbound connections are using TLS 1.2.  Kofax will not be able to assist with these configurations.

 

**Update:  As of May 1st 2022, the deadline for enforcing TLS 1.2 connections via the API and the Target System Integrations has been extended for a short period of time.  However, TLS 1.2 is now required for connections via a Web Browser.
 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
AP Essentials all      

 

References

Enabling TLS in your web browser
https://docs.readsoftonline.com/help...bling_TLS.html

Upgrading AP Essentials Connect to support TLS 1.2
https://knowledge.kofax.com/ReadSoft...upport_TLS_1.2

AP Essentials Connect version info
https://knowledge.kofax.com/ReadSoft...t_version_info

 

 

Article # 3030887
  • Was this article helpful?