Skip to main content
Kofax

What TLS version is required to connect to AP Essentials?

Article # 3030887 - Page views: 71

Issue

What TLS version are required for AP Essentials (formerly ReadSoft Online)?

 

Solution

There are several methods which can be used to establish connections to Kofax AP Essentials:

  • User Interface via a Web browser
  • AP Essentials connect utility
  • AP Essentials API

Currently each of these methods allow for TLS 1.0/1.1/1.2 connections. However, in the very near future, Kofax AP Essentials will remove support for TLS 1.0/1.1 and require all connections to use TLS 1.2.

Connecting to the UI via a web browser:
Please make sure your Web Browser supports TLS 1.2 connections.   Please see the KB articles referenced below for additional information.

AP Essentials Connect:
Please make sure the version of AP Essentials Connect installed on your machine is greater than or equal to version 10.4.7451.  Please see the KB articles referenced below for additional information.

API:
For custom code developed using the API, please contact your Partner or third-party developer to ensure your custom code utilizes TLS 1.2.


**Update:  As of May 1st 2022, the deadline for enforcing TLS 1.2 connections via the API has been extended.  However, TLS 1.2 will be enforced for connections via a Web Browser or via AP Essentials Connect.
 

Level of Complexity 

Moderate

 

Applies to  

Product Version Build Environment Hardware
AP Essentials        

 

References

Enabling TLS in your web browser
https://docs.readsoftonline.com/help...bling_TLS.html

Upgrading AP Essentials (formerly ReadSoft Online) Connect to support TLS 1.2
https://knowledge.kofax.com/ReadSoft...upport_TLS_1.2

AP Essentials Connect version info
https://knowledge.kofax.com/ReadSoft...t_version_info

 

 

Article # 3030887
  • Was this article helpful?