Skip to main content
Kofax

ReadSoft: Java Version (new license cost/requirement) for Web Application

3023291

Question / Problem: 

Oracle is changing their pricing model and they will no longer be including licenses for Java usage.   Does the Kofax Web Application license include the Java license or will we be required to purchase the licensing?

Answer / Solution: 

We support JRE 8 and every later version.

Our application uses the standard JRE functionalities according to OpenJDK standard. We do not require the OracleJDK, but we do require a JRE. Any JRE of version 8 and higher that is compatible to the JRE standard, is supported by us. 

We do not provide any Java license.  We require Java for our application, but what JRE you use is up to the you.  If you decide to go with Oracle, and wish to have long term enterprise support for it, you will have to make a license agreement with Oracle. You can, however, also use other JREs like the OpenJDK-JRE or Amazon Corretto.

In short: Our Web Application requires a Java Application Server (e.g. Tomcat). This server requires a Java Runtime Environment to work. Our application sets the restriction that JRE is at least version 8, and is compatible to the OpenJDK standard. We do not provide any JREs ourselves, or any licenses for 3rd party vendors like Oracle.

Applies to:  

Product Version
Process Director Web Application  

 

 

  • Was this article helpful?