PROCESSIT : Failure in process D4_ACCOUNT_AND_APPROVE
Article # 3040834 - Page views: 13
Issue
- Every day a few invoices fail in process D4_ACCOUNT_AND_APPROVE and we have noticed that the error mentions ‘closed connection’. Is it possible to check what is going on with these invoices?
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The problem began after we migrated our Oracle EBS environment from OMCS to OCI.
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It happens ou various times of the day.
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It does not happen in non-production.
Cause
- This more than likely has nothing to do with the oci changes to ebs database and more to do with the processit database.
Solution
- Attached is a document which shows settings for updating jta transaction timeouts.
- This is the best place to start to check.
- If this doesn't do it or the jta transaction settings are already set, then perhaps there is a limitation to the number of connections against the d4 and orabpel schemas within the processit database.
- The connections at one point were open but then closed. which is a probable indication of the transaction timeouts as a cause.
- Also look at the soa enterprise manager under administration of the oc4j_soa instance.
- Check the jdbc connections > BPELPM_CONNECTION_POOL.
- View the attributes and note.
- The issue is likely either connection pool or the soa database is exceeding the number of allowed connections from the database itself.
- Check the jdbc connections > BPELPM_CONNECTION_POOL.
Level of Complexity
Moderate, High
Applies to
Product | Version | Build | Environment | Hardware |
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PROCESSIT | 7.3.3.17 |
References