Document stuck in workflow
Article # 3043899 - Page views: 149
Issue
A document is stuck in workflow (could not be rejected, canceled or processed anymore).
Some examples:
- The document was not approved and was allowed to post and stuck in workflow (something in workflow functionality).
- The document was approved, but the workflow status did not change (something in workflow functionality).
- The document was in workflow, when a change was made to workflow configuration.
Cause
Some possible causes:
- Wrong workflow functionality
- User Exit
- Wrong workflow step customizing
Solution
Review the 3 solutions below to determine which will resolve your issue:
- Run the /cockpit/wc_delete program using transaction SE38 if it is isolated to one or two documents or if you need to process the documents now. This removes the document from all workflows and sets the document status to error. You must then re-process the document through all workflows and post it again (if it was posted). Test this in your test environment so you understand what it does before running it in production.
- Run the /cockpit/wc_reset_status (if available in your version) using transaction SE38 if it is isolated to one or two documents or if you need to process the documents now. You will choose to either change the Workflow status to With errors OR to change to previous status. Test this in your test environment so you understand what it does before running it in production.
- Replicate in a test system if this is a continuing issue so we can troubleshoot and provide a resolution.
Level of Complexity
Moderate
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
Process Director Accounts payable | > 7.4 | SAP |
References
Check the Kofax Work Cycle Configuration Guide for your version for more information -- https://kofaxinc.sharepoint.com/site...ages/Home.aspx
Article # 3043899