Mails are not processed. Error: The underlying connection was closed: An unexpected error occurred on a send
Issue
Emails from Outlook Office 365 are not being picked up and processed by Collector
The Collector logs are showing the following error:
Connection to the Exchange server failed. Message: The underlying connection was closed: An unexpected error occurred on a send
Cause
Microsoft has enabled TLS 1.2 for Outlook 365
Microsoft is discontinuing basic authentication for example (IMAP)
https://docs.microsoft.com/en-us/lifecycle/announcements/exchange-online-basic-auth-deprecated
Solution
1 - COLLECTOR version should be 6.5.0.4 or higher to use TLS 1.2.
If you are using this version or higher you then need to configure the following parameter SecurityProtocolType=4 (See references below) in the Collector.ini file. Then restart the services for the change to take effect.
2 - If the above step has not resolved the issue and you are using OAuth as the connection method to the mailbox then please review the following article
Failure to connect using OAuth with Office 365 or Exchange Web Services in a TLS 1.2 environment (https://knowledge.kofax.com/ReadSoft....2_environment)
3 - If the connection method is not OAuth, then you will need to change the connection method from EWS/IMAP to modern authentication (OAuth).
Please review the following article https://knowledge.kofax.com/ReadSoft/ReadSoft_Invoices/Reference/An_Overall_Guide_to_Modern_Authentication_using_OAuth_for_INVOICES_and_COLLECTOR
Level of Complexity
Complex
Applies to
Product | Version | Build | Environment | Hardware |
---|---|---|---|---|
INVOICES COLLECTOR |
> 58 sp2 >6.5.0.4 |