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153 - No access to workdir error in Transfer

Article # 3038264 - Page views: 51

Issue

When attempting to start a Transfer job, the following message is displayed, "153 - No access to workdir <folderpath>," where folder path is part of the installation directory for Invoices. For example, the folder path may be C:\Program Files(x86)\ReadSoft\INVOICES\Plugins.

Cause

In a heightened security environment, administrators may limit access to system directories, such as Program Files and Program Files(x86). This may result in the Transfer module failing to have proper access to the Workdir to process files during transfer.

Solution

Either of the following solutions will restore the system to service.

1. The user account for which the Transfer module runs can be granted full control to the directory in the message, e.g. C:\Program Files(x86)\ReadSoft\INVOICES\Plugins.

2. The EILOCAL.ini file can be updated to use a Workdir directory of the administrator's choosing. For example, if the EILOCAL file for the Transfer server is located in the default location, C:\Users\Public\ReadSoft\INVOICES, the following section in the EILOCAL can be updated as shown to specify the Workdir directory there.

[eitran::Eicc]
Name=INVOICE COCKPIT Connector
Type=COM
SupportIDispatch=TRUE
ClassName=Eicc.clsRoot
Workdir=C:\Users\Public\ReadSoft\INVOICES\Workdir

Note: The server admin may have to create the Workdir directory with proper permissions before the Transfer module is started.

Remember, the Transfer module will have to be restarted before the new settings can be loaded.

Level of Complexity 

High

 

Applies to  

Product Version Build Environment Hardware
Invoices All      
Invoices Cockpit Connector All      

References

Finding the EILOCAL INI file in an Invoices solution: https://knowledge.kofax.com/ReadSoft...OICES_solution

 

Article # 3038264
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